Dodge Avenger Forum banner

ignition

  1. 2013 Avenger Will Not Crank or Start

    Dodge Avenger Electrical Problems and Questions
    Hello, I have a 2013 Dodge Avenger. It has the following symptoms: -When I turn the key to ignition, I can hear some clicking - but it doesn't sound like the starter solenoid. It dims the lights and dash indicators. -The car functions normally (accessories, lights, etc) when key set to "ON" or...
  2. Anti theft system shutting off car?

    Dodge Avenger Electrical Problems and Questions
    To anyone who can help, I am in need desperately after my car is not working properly. I recently needed to change the battery to my key fob and while I was changing it outside of my car I needed to get something from inside the car. Little did I realize that I had dropped it after I had shut...
  3. Relay/TIPM problem

    Dodge Avenger Electrical Problems and Questions
    Hi folks, I am having A/C problems with my car, so I ran an OBD scanner today and I am getting the following codes P0645, P0688 and P0685 all pointing to a relay issue (one of them being A/C clutch relay). I pop the hood open the relay compartment and find this (picture below). One of the...
  4. Avenger no-start condition & TPM System failure

    Dodge Avenger Mechanical Problems and Questions
    Hey everyone, I'm new to the forums as of a few moments ago, making this my first post (obviously). Unfortunately, my first post is going to be a desperate cry for help. I've posted the following on the Dodge Avenger/Chrysler 200 Nation group page on Facebook, so I've copied & pasted it here in...
Top