Dodge Avenger Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-4 of 4 Results
  1. Dodge Avenger Mechanical Problems and Questions
    Hi, I'm new to the forum. I've been a lurker for awhile though as I've previously owned a 2010 Avenger and I just purchased a 2009 Avenger SXT. So my 09 is in great shape, only 100,000km on it (roughly 62,000 miles) and the only thing wrong was it needed a front subframe replacement and the...
  2. Dodge Avenger Mechanical Problems and Questions
    Hello everyone, ok so I have a 2014 SE 2.4L 123,000 miles.. I changed the motor mounts cause they had to be changed even though I replaced them 2yrs ago, But after replacing them, now o_Owhen you put the car in reverse it vibrates pretty good,but if you turn the wheel a little bit it will...
  3. Dodge Avenger Mechanical Problems and Questions
    So, I have a 2013 Canada value package, 2.4l with the 4 speed trans. If I go above 50 kmh (about 30mph) and give it some gas, but not enough to down shift the car starts to vibrate and it produces a noise similar to wind buffeting. I checked trans fluid and it looks good as new. There's no...
  4. Dodge Avenger Mechanical Problems and Questions
    Hi there! First time poster. Having some issues. Hoping this community can help me out! I love my 2009 Dodge Avenger SXT more than anything. It is my first car, and it took a long time to save up for it. I bought it used 2016 at 120,000 miles on the East Coast. I drove it to where I live in...
1-4 of 4 Results
Top