Dodge Avenger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
If this has been discussed I apologize.

About a week ago while out driving around I noticed my brakes went straight to the floor when pressed. I found a spot under the car where the brake lines being held in was severely rusted and was leaking from behind the bracket. I ran new lines around the trouble area to the rear brakes. I have bled all four brakes, including the master cylinder. But for some reason I have no brake pressure when the car is running. When I turn the car off the brakes build pressure after one or two pumps of the pedal. Has anyone had similar issues or know what might be a solution? Thank you in advance!
 

·
Premium Member
Joined
·
6,527 Posts
Hello, and welcome to the forumz.
Does this Coupe have the optional ABS brake system?
In my opinion, for both brake systems, you still have air in the brake lines. An ABS equipped system is a bit harder to bleed out and may require special procedures to do.
 

·
Registered
Joined
·
4,134 Posts
If there are no visible leaks it could also be your master cylinder. The internal seal might be wearing.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hello, and welcome to the forumz.
Does this Coupe have the optional ABS brake system?
In my opinion, for both brake systems, you still have air in the brake lines. An ABS equipped system is a bit harder to bleed out and may require special procedures to do.
I have not seen any ABS lights on my dash through everything, so I am inclined to say it doesn't have ABS
 
1 - 6 of 6 Posts
Top