Dodge Avenger Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
So, the past 2 weeks I have been monitoring my A/C flow and I have had 3 other people also feel to see if what I am about to say is wrong....but they had the same experience that I have been having......

Out of 4 vents on the front dash (1 at each window and 2 in the center console) the 2 that are on the drivers (window and one center console) side blow warm air when the air coming from the passenger side vents is cold, like it should be with the A/C running. Why is this?

Anyone else had similar issues? Now after the system has been running on high and "max circ" for 10 minutes or so the drivers sides 2 vents start to feel cooler but not cold like the passenger side. Is there another set of coils or something on the drivers side that is making the system pull hot air from that side? The air flow is fine, blower working just fine......but those 2 vents blow warm air.

Of course I am seeking any help prior to me having to go get it serviced. I would greatly appreciate any input.
 

·
Registered
Joined
·
5,054 Posts
It could be one of your blend door actuators. They are behind the glove box and separate/control hot and cold air. If you had any clicking sounds from behind the dash, that would be the problem.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
AC issues

I had a guy pull the back of my glove box out about 2 months ago, looking to see if there was an amp hooked to my radio (I was thinking of getting the stock radio replaced but have not yet) and if this thing is behind there then maybe he accidentally messed something up.....hm,mmmmm

So behind the glove box? If I pulled it out would I know what to look for or look at to see if this is the case? It would make sense if this was the case.....
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
cool!

Thank you for sharing that with me. If time allows after work today I will check it out....or this weekend. TY! TY! TY!
 

·
Registered
Joined
·
5,054 Posts
No problem, really hoping it solves your problem.
 

·
Registered
Joined
·
5 Posts
They also do this in the summer time when it's hot out and the freon is a little low. Right side tends to blow cold and left side "cool". Based on current temps across most of the USA, the low side pressure at 3/4 fan speed and max A/C should be between 48-52psi (high side pressure around 240 +/- 5%. If the system has ever been exposed to atmosphere, moisture and air in the system can ALSO cause this problem.
 

·
Registered
Joined
·
1 Posts
So, the past 2 weeks I have been monitoring my A/C flow and I have had 3 other people also feel to see if what I am about to say is wrong....but they had the same experience that I have been having......

Out of 4 vents on the front dash (1 at each window and 2 in the center console) the 2 that are on the drivers (window and one center console) side blow warm air when the air coming from the passenger side vents is cold, like it should be with the A/C running. Why is this?

Anyone else had similar issues? Now after the system has been running on high and "max circ" for 10 minutes or so the drivers sides 2 vents start to feel cooler but not cold like the passenger side. Is there another set of coils or something on the drivers side that is making the system pull hot air from that side? The air flow is fine, blower working just fine......but those 2 vents blow warm air.

Of course I am seeking any help prior to me having to go get it serviced. I would greatly appreciate any input.
It could be one of your blend door actuators. They are behind the glove box and separate/control hot and cold air. If you had any clicking sounds from behind the dash, that would be the problem.
I have replaced 2 of my blend door actuators that were broke or clicking. Now my right side only blows cold but left blows warm, unless i am driving fast then its cool, but still not as cold as right side is.

Seems to get less cool from right to left
 
1 - 8 of 8 Posts
Top