Dodge Avenger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2010 avenger 2.4l r/t
Its my wife's car
Bought it 5 years ago, so far no problems
Two days ago when leaving work it started shaking right after starting. Check engine light came on (flashing).
She turned car off and back on and just came straight home (light was off now)
Now I just went and started it, it started shaking (rougher than the usual) almost like a stutter but the idle sounded good and rpm Guage held steady.
Check engine light started flashing again. But I don't know how to check the code without taking it a store.
Any help would be appreciated.
 

·
Registered
Joined
·
1,472 Posts
Do the Key Dance. It works when no code reader is available. Use the search tab to find the details on how to use and interpret.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I have a 2010 avenger 2.4l r/t
Its my wife's car
Bought it 5 years ago, so far no problems
Two days ago when leaving work it started shaking right after starting. Check engine light came on (flashing).
She turned car off and back on and just came straight home (light was off now)
Now I just went and started it, it started shaking (rougher than the usual) almost like a stutter but the idle sounded good and rpm Guage held steady.
Check engine light started flashing again. But I don't know how to check the code without taking it a store.
Any help would be appreciated.
Do the Key Dance. It works when no code reader is available. Use the search tab to find the details on how to use and interpret.
I tried that, just reads ------- and the says done.
 

·
Registered
Joined
·
4,908 Posts
Purchase an OBD reader or take the car in to a local part supplier like Auto Zone. They can do a reading for you.
 

·
Registered
Joined
·
1 Posts
I have a 2010 avenger 2.4l r/t
Its my wife's car
Bought it 5 years ago, so far no problems
Two days ago when leaving work it started shaking right after starting. Check engine light came on (flashing).
She turned car off and back on and just came straight home (light was off now)
Now I just went and started it, it started shaking (rougher than the usual) almost like a stutter but the idle sounded good and rpm Guage held steady.
Check engine light started flashing again. But I don't know how to check the code without taking it a store.
Any help would be appreciated.
Mine did something that similar but not as bad, it's the motor mounts. Easy fix you can get them online cheaper than the auto part store
 

·
Registered
Joined
·
116 Posts
How do the engine mounts look?

I recently had to replace my '12 RT engine mounts... Safety inspection caught them. It did return the smoothness I barely noticed I was missing.
 
1 - 7 of 7 Posts
Top