Dodge Avenger Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
runs good till you stop or hit 30, then completly starts shaking bad.sometimes it even dies
changes coils and spark plugs and also crankshaft twice and still does the same anyone out there know the solution to get it running back good?
 

·
Registered
Joined
·
5,105 Posts
Have you used a scanner to check for codes?
 

·
Registered
2008 Chrysler Sebring 2.4L
Joined
·
63 Posts
You've replaced the crankshaft twice? Was the rotating assembly properly balanced?

What about wheel alignment/balance?

Bushings/ball joints/engine mounts?

Are your brakes dragging or rotors warped?

How does one even diagnose that the crankshaft is the cause of a car's vibrations?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
You've replaced the crankshaft twice? Was the rotating assembly properly balanced?

What about wheel alignment/balance?

Bushings/ball joints/engine mounts?

Are your brakes dragging or rotors warped?

How does one even diagnose that the crankshaft is the cause of a car's vibrations?
the way you press on the gs
You've replaced the crankshaft twice? Was the rotating assembly properly balanced?

What about wheel alignment/balance?

Bushings/ball joints/engine mounts?

Are your brakes dragging or rotors warped?

How does one even diagnose that the crankshaft is the cause of a car's vibrations?
ofc all were checked its litterally something with electrical and or wiring, im not sure but if any of what you said were messed up then why would turning it on and off automatically fix it
 
1 - 5 of 5 Posts
Top