Dodge Avenger Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey there!

My questions is simple but I need your experience. Does the 2.4L 13 Avenger have a IMRC? I find videos of replacement on a 2008 and 2009 but none on 2013 models. When I search for this part to buy, the search is directed to older models. I ask because I was working on this car and I am not seeing this part being attached to the intake manifold as seen on previous models. There are three holes of where the bolts would go and a little metal nub looking piece in the middle. Is this part simply not made for the 2013 model?

Also, I am getting the p0171 code and I replaced the manifold gasket, problem still there. I understand it could be different things and i'm still looking into that. Could someone direct me to where the MAP sensor is? It may need some cleaning.

Thank you
 

·
Registered
Joined
·
1,029 Posts
The images that I see online of the intake manifold show it but who knows if it’s ‘11+ or not. Couldn’t find anything in the Haynes manual.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
I ran through the same issue, there are many intake manifolds for this car that have it but cannot determine what year they are. The ones I've confirmed are 2008 and 2009 so far =/.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
My preoccupation is that the first owner or someone who previously worked on this car took it out and cut the connecting plug. I am not seeing the connector for this IMRC valve on this car. However, I am seeing the three holes of where the bolts would be inserted, it just looks like the part is missing...
 

·
Premium Member
Joined
·
6,466 Posts
I would suggest getting "preoccupied" with following the diagnostic procedures for the P0171 code(lean fuel).An IMRC would set its own code if even left unconnected, or the connector cut off.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
I can understand that; however, there may have been a wiring modification of sorts. I'm not seeing any confirmation on that matter unfortunately. The CEL with code P0171 may just be a dirty fuel filter or the MAP sensor being dirty, the manifold gasket has been replaced and the Oxygen Sensors are not the issue. There is low power, at higher RPMs. It could be an exhaust leak, but no signs of oxidation or punctures and vacuum lines are not cracked or leaking air at all.
 

·
Premium Member
Joined
·
6,466 Posts
Well what an independant shop or DIYer may have done with physical parts, we can not tell you. BUT I seriously doubt that they could go in and change programming of the cars computer to not show codes for lack of readings from a missing IMRC. So my opinion is that unless a whole lot of work was done, and that with searching myself and finding no part listing for it, that your year does not use the IMRC. Also not stated, do you have the "normal" or "PZEV" version of the 2.4? A PZEV "reburns" exhaust gases under specific running parameters and may be a possible fault area in that system. Are there any other codes than the singular one you posted?
 
1 - 9 of 9 Posts
Top