Dodge Avenger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ok guys and gals I’m new here so forgive me if I miss something.
my wife has a 2014 RT that has 96000 miles and has developed a humming/ vibration issue in the front. Sounds like passenger side but I’m not positive. First thought was tires. It needed them so I got new tires. I have also replaced front wheel hubs and and strut assembly’s and nothing has fixed it. You can start to hear the noise when you get to about 20mph and it’s very noticeable at 50mph. It gets quieter as you slow down. I can feel the vibration in the floor at about 50mph also. Please help as I’m about to lose my mind with this thing.
thank you
 

·
Premium Member
Joined
·
6,635 Posts
Since you say that front bearings were replaced... that would leave the pass. side axle shaft support bearing. Yes it is a 2 piece shaft, and the support bearing is on the transaxle side of it. Most people get confused and just get the short outer side with the outer(wheel) and inner CV joints, That particular shaft won't "fill the bill" in getting the support bearing section.
Have a better Labor Day Weekend and stay healthy! :)
 

·
Premium Member
Joined
·
6,635 Posts
It is a bit of a chore, but not earth shattering. There are a number of threads posted on changing the pass. side axle shaft, and a few by some who found the actual bearing part number and were able to replace the bearing alone(some skill and somewhat special tools incoved).
Reason for the 2 pc. axle shaft was to reduce "torque steer" effect during brisk acceleration and been used in FWD MOPARS from the time of the K cars (1980's).
 

·
Premium Member
Joined
·
6,635 Posts
COULD also be the power steering PUMP you're hearing, Been a number of threads posted in the past of P/S PUMP noise. Still not the easiest of chores......
 
1 - 6 of 6 Posts
Top