Dodge Avenger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello fellow avenger enthusiasts,

Lately I have been having issues with my 2013 Avenger 3.6L shuttering and often times flat out dying when I am rolling/coasting to a stop. Does not matter slow or fast rate of deceleration as it will happen while crawling through a drive-through. Feels like the engine is stalling and RPM dip below regular idle. If I apply a small amount of gas during early shuttering can prevent the stall. Power supply from battery is present/consistent but ignition requires restart. Engine turns over fine.

Fuel injectors, maybe? Something else? Has anyone used additives to fuel to maintain/restore engine performance? What kind did you use? Suggestions please! Thanks in advance!
 

·
Premium Member
Joined
·
6,563 Posts
How many miles on the car and what maint. has it had(plugs, throttle body cleaning,etc) Yes run a can of SeaFoam in the gas tank and let it work thru, I've had great results using it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
65,000. Maintenance consists of basic/regular fluid changes and k&n filter cleaned regularly. Last thorough inspection done was @55k when transmission required replacement. Transmissin would not shift beyond gear 3 - it would attempt to shift to 4th and subsequently drop to 1st. At the same time, it was discovered that one of the harmonic balancers was breaking loose - this issue was also addressed and corrected at 55k miles both covered under warranty.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Not sure if previous repairs are relevant to current issue though still an important factor to vehicle history.
 

·
Premium Member
Joined
·
6,563 Posts
Is the CEL on when driving and scanned for codes since this "stalling" started happening?
Spark plugs should be ok yet(90-100k miles)
Sorry to hear of the trans. problem!
 

·
Registered
Joined
·
1,397 Posts
Get rid of the K&N and go to a blue dry filter that is washable. There are report on different forums about oil from the filter getting out and gumming up the throttle body and other sensors.
 
1 - 6 of 6 Posts
Top