97 avenger uni-body repair

Discussion in 'Pre 2007 Dodge Avenger General Discussion' started by bhawk509, Oct 29, 2014.

  1. bhawk509

    bhawk509 Member Military

    Joined:
    Oct 29, 2014
    Messages:
    126
    Likes Received:
    37
    Gender:
    Male
    Location:
    Albany NY
     
  2. bhawk509

    bhawk509 Member Military

    Joined:
    Oct 29, 2014
    Messages:
    126
    Likes Received:
    37
    Gender:
    Male
    Location:
    Albany NY
    I put seaform in the tank and sprayed sea form in the throttle body as well,have not had a chance test drive it as yet will see later today.
     
  3. 5rebel9

    5rebel9 Active Member Site Supporter Level 1 Military

    Joined:
    Dec 9, 2015
    Messages:
    3,250
    Media:
    29
    Albums:
    3
    Likes Received:
    696
    Gender:
    Male
    Location:
    NY 14777
    Ah, a NICE Sunday evening Cruise? Don't forget to take the Mrs.!!:D
     
    bhawk509 likes this.
  4. 5rebel9

    5rebel9 Active Member Site Supporter Level 1 Military

    Joined:
    Dec 9, 2015
    Messages:
    3,250
    Media:
    29
    Albums:
    3
    Likes Received:
    696
    Gender:
    Male
    Location:
    NY 14777
    Have not read any gripe sheet's on your 'Venger, is the logbook showing 100% up status yet?
     
  5. bhawk509

    bhawk509 Member Military

    Joined:
    Oct 29, 2014
    Messages:
    126
    Likes Received:
    37
    Gender:
    Male
    Location:
    Albany NY
    Still stalls sometimes after cleaning throttle body and adding seaform to gas tank.After doing some research on the idle being 200 RPM to low, Ordered Idle Air Control Valve from ebay, we will see what that does.
     
  6. 5rebel9

    5rebel9 Active Member Site Supporter Level 1 Military

    Joined:
    Dec 9, 2015
    Messages:
    3,250
    Media:
    29
    Albums:
    3
    Likes Received:
    696
    Gender:
    Male
    Location:
    NY 14777
    Check the many vacuum lines that are hooked onto the intake manifold,especially the PCV line, at the age of our cars the rubber hoses are old and hard and could be splitting open at connecting ends. All it takes is one small leak and IAC will try and bring rpms back down, Heat of running may bring this on, as you say "sometimes stalls".
     
  7. bhawk509

    bhawk509 Member Military

    Joined:
    Oct 29, 2014
    Messages:
    126
    Likes Received:
    37
    Gender:
    Male
    Location:
    Albany NY
    Other than looking at all vacuum lines for damage, is there another way to check?
    Did not see any problems with the vacuum lines,but Ill look again thanks!!
     
  8. 5rebel9

    5rebel9 Active Member Site Supporter Level 1 Military

    Joined:
    Dec 9, 2015
    Messages:
    3,250
    Media:
    29
    Albums:
    3
    Likes Received:
    696
    Gender:
    Male
    Location:
    NY 14777
    Not really that I know of, other than GOOD visual inspection, there are a number of vacuum lines and any one of them can cause the symptom you describe. Could even be a "hanging open EGR valve,and that is kind of a "toughy" to get to. Think from age outlook,most commonly rubber vacuum hoses. Where is RPM when cold started and once warmed up without driving?
     
    bhawk509 likes this.
  9. bhawk509

    bhawk509 Member Military

    Joined:
    Oct 29, 2014
    Messages:
    126
    Likes Received:
    37
    Gender:
    Male
    Location:
    Albany NY
    idling about 500 RPM in drive,suppose to idle at 700 plus or minus 100 cold or warmed up
    .
     
  10. bhawk509

    bhawk509 Member Military

    Joined:
    Oct 29, 2014
    Messages:
    126
    Likes Received:
    37
    Gender:
    Male
    Location:
    Albany NY
    Replaced the EGR valve about 5 years ago,ill check it again thanks!!
     
  11. 5rebel9

    5rebel9 Active Member Site Supporter Level 1 Military

    Joined:
    Dec 9, 2015
    Messages:
    3,250
    Media:
    29
    Albums:
    3
    Likes Received:
    696
    Gender:
    Male
    Location:
    NY 14777
    Seeing how you say "sometimes"I think IAC is OK, but closing down more than normal to account for some kind of vacuum leak. Good hunting to you, I hope to hear that all pilots "gripes" are fixed and craft at 100% up status SOON!

    EDIT: short shots of carb cleaner spray would find an open/cracked vacuum line when sprayed at various hoses, you would tell by the RPM's raising when such a line is found. DO NOT try this around the EGR valve.
     
    Last edited: Aug 28, 2017
    bhawk509 likes this.
  12. bhawk509

    bhawk509 Member Military

    Joined:
    Oct 29, 2014
    Messages:
    126
    Likes Received:
    37
    Gender:
    Male
    Location:
    Albany NY
    Thanks good idea!!! Ill give it a try tomorrow.
     
  13. 5rebel9

    5rebel9 Active Member Site Supporter Level 1 Military

    Joined:
    Dec 9, 2015
    Messages:
    3,250
    Media:
    29
    Albums:
    3
    Likes Received:
    696
    Gender:
    Male
    Location:
    NY 14777
    OH Mr. Blackhawk..where are you? Hope lack of checking in is due to long, FUN "hops" with your Coupe and not continuing "gripes"!
    If still stalling, you said you replaced EGR Valve a while ago, did you replace the EGR Transducer with it? That is the actuator to open and close the valve.
     
  14. bhawk509

    bhawk509 Member Military

    Joined:
    Oct 29, 2014
    Messages:
    126
    Likes Received:
    37
    Gender:
    Male
    Location:
    Albany NY
    I replaced the throttle body and idle control valve now I have a rough Idle just cannot win!!LOLOL
     

Share This Page