Dodge Avenger Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
I'm looking for the low pressure port but everywhere I go describes the high pressure port.

Would recharging the wrong one indicate anything?
 

·
Registered
Joined
·
1,029 Posts
Mine is blowing hot air as well. Haven’t looked into it yet though as I can probably count the number or times I’ve used my a/c on one hand in the 6 years I’ve owned the car.
 

·
Registered
Joined
·
81 Posts
Mine is blowing hot air as well. Haven’t looked into it yet though as I can probably count the number or times I’ve used my a/c on one hand in the 6 years I’ve owned the car.
Does it not get uncomfortably hot there in summer? In Phoenix I use my car's AC regularly from May to October, and once in a while the remaining months if I have temperature sensitive food in the car in mid-day.
 

·
Registered
Joined
·
56 Posts
Have any of you had to switch out your compressors on models from 08 and above?? I thought mine was bad but after putting a subzero can in it now blows cold but only on the passenger side. Any thought??
 

·
Premium Member
Joined
·
7,143 Posts
Have any of you had to switch out your compressors on models from 08 and above?? I thought mine was bad but after putting a subzero can in it now blows cold but only on the passenger side. Any thought??
You really need to have a set of A/C gages hooked up and check the high and low press readings. Too much refrigerant and it won't get that cool, too little and it has been posted often here that drivers side won't cool as well as the pass side.
 

·
Premium Member
Joined
·
7,143 Posts
IF it was blend door actuators, you would also have the same problem when using heat and not just A/C. Maybe do a bit more diagnosis of the whole operation of the HVAC system to better determine just what is going on.
 
1 - 15 of 15 Posts
Top