Dodge Avenger Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello everyone I am currently under the hood of my avenger and want to check if my belt is routed properly (cuz I might haves goofed up putting it back on after alt. Change) but no matter where I look on the Internet all I have come close to has been diagrams of 2.4s or chargers all of which have the pullys in the wrong place compared to mine. If it is routed wrong that will save me from having to replace the water pump and I really don't want to fiddle with that if I don't have to (can't get the two front tires off so it makes everything that much harder) any help would be appreciated
 

·
Registered
Joined
·
5,785 Posts
This should help:

3.6L




  1. Check the condition of all the pulleys.



    CAUTION
    When installing the serpentine accessory drive belt, the belt MUST be routed correctly. If not, the engine may overheat due to the water pump rotating in the wrong direction.


  2. Route the serpentine belt around all the pulleys except the idler pulley (2). Rotate the belt tensioner (8) until it contacts its stop position. Route the serpentine belt (7) around the idler (2) and slowly let the tensioner (8). Make sure the belt (7) is properly seated onto all pulleys.



  3. With the serpentine belt installed, inspect the belt wear indicator. The gap between the tang and the housing stop (measurement A) must not exceed 24 mm (.94 inches).
  4. Install the wheel house splash shield.
  5. Install the tire and wheel assembly.
  6. Remove support and lower the vehicle.
  7. Connect the negative battery cable.
 
  • Like
Reactions: DLR2021
1 - 3 of 3 Posts
Top