Dodge Avenger Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
After getting code P2004, I took the intake manifold off to see if the runners were stuck. They were not. I believe the issue is just the position sensor on the side. Problem is, I broke off the center bolt when replacing the intake manifold. Before taking everything off again, I would like to replace the IMRC and see if that solves the problem.

Do I dare drive this car at all before taking care of the broken bolt situation? If I'm going to go through all this again, I want to know whether or not the intake manifold needs to be replaced. I don't want to do it a third time!!
 

·
Premium Member
Joined
·
7,314 Posts
When operating an engine with dis similar materials,(PLASTIC intake manifold,metal cylinder head and a rubber "o" ring gasket to seal) NO I would NOT run it. As warping can occur and vacuum leaks happen that will make driving it worse and more costly to repair.
I surmise that you have the 2.4L 4 cyl. motor? Please fill in motor size in your profile info., and then drop by the newbie checkin page and intro. yourself to the whole forumz family!
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 · (Edited)
Thought I would post an update in case anybody else searches on broken bolt. I was not able to find the bolt at a hardware store, farm store, or auto parts store. As a last resort I called my Dodge dealer. I was pleasantly surprised that they charged me only $1.45!! I did have to wait 2 days for them to get it in, but I expected the price to be 10 times that.
 

·
Premium Member
Joined
·
7,314 Posts
Glad you able to get that situation resolved. now keep us informed as to the original problem being "worked out"!
 
1 - 5 of 5 Posts
Top