Dodge Avenger Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So, last night, my girlfriend was driving her '08 Avenger. The car started to stop running and she pulled over. By the time she stopped the car was off and would not start again. Someone stopped to help her and hooked up jumper cables and as he was trying to crank it something started to smoke from the engine bay. I was not there so I can't explain how it smelled or looked. So, now, I am trying to figure out what is going on. This morning I got to the car, turned the ignition and it slowly attempted to turn over. When I hooked up the jumper cables it stopped even doing that and now it will not click or make any noises when I turn the key to start it. I have full power everywhere else, lights, radio, everything seems to light up fine. Any ideas?
 

·
Premium Member
Joined
·
6,466 Posts
Would be helpful to post what engine, miles on the car and any recent work done to get better help.
Also due to seeing "smoke" does the engine turn if you put a socket and breaker bar to the crank pulley bolt? This would determine if the engine seized or if it may be a starter motor gone bad. As far as "stalling out" while driving, could also be a problem with battery and cable connections, which should be checked also. YUP a pain to access thru the LF wheel well.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
It's the 2.4L with 20000 miles. I have someone helping me here now, we have the battery out and trickle charging it to see if it's good. If it is we will go from there. Hopefully he can figure it out
 

·
Registered
Joined
·
1,379 Posts
Is that 20,000 or 200,000. For a 2008 I am thinking the latter. How old is the battery, what is the maintenance record like?
 
1 - 4 of 4 Posts
Top