Dodge Avenger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey all, first time poster here, long time follower.

I have a 13' SE and my horn plate chirps like an angry bird at all speeds, including idle.

It is very annoying and I have been ignoring it for quite some time!

Can anyone provide the steps to remove the wheel cover/horn plate and resolve this issue once and for all?

Thanks in advance. <3
-Your friendly neighborhood Avenger.
 

·
Premium Member
Joined
·
6,806 Posts
Welcome to the Forumz, please post in at the Newbie Check in page to introduce yourself and ride.
Pretty sure that there are a few threads already posted of the Air bag/horn pad cover removal process along with the fix to tighten up the mounting to get rid of that squeak. The forum search function is a great tool, and the process is pretty much the same for all years of the Sedans.;):)
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
I can assure you I wouldn't waste your valuable time if I hadn't tried searching it myself. Would you mind linking me to this post and perhaps pinning it for our vengeance-seeking friends? It seems to be a common enough issue. Again, thank you! :)
 

·
Premium Member
Joined
·
6,806 Posts
IF I had the whole day to try and post a link to what you are looking for, I MIGHT be able to accomplish that. I have a big problem with computer skills and the way my PC is set up to do such:rolleyes:. I am very active with the Forumz here, but that type request is beyond my capabilities:(.
Perhaps some of our other more computer savvy members can do this for you. BUT the basics are to disconnect battery power and wait 30 minutes and unbolt and disconnect the air bag. Then either "shim" the springs or expand the springs to give more tension to the set up it has. Not a very difficult task to do once you get a look at it. ..try looking up a you tube about it also.:)
 

·
Registered
Joined
·
4,709 Posts
1 - 7 of 7 Posts
Top