Dodge Avenger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2012 Dodge Avenger Sxt+ and it’s misfiring in number 2-4-6. Only will misfire while in park and when I rev it all of them stop misfiring. When I sit in drive it still won’t misfire. Started after I did compression test and replace intake manifold gaskets.
 

·
Premium Member
Joined
·
6,806 Posts
Sad to say the obvious, but if it did not do it before work done, then it's time to go back in and recheck your work.
WHY was the work performed and what about thins like spark lugs ever being replaced on this unknown to us mileage ride?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Sad to say the obvious, but if it did not do it before work done, then it's time to go back in and recheck your work.
WHY was the work performed and what about thins like spark lugs ever being replaced on this unknown to us mileage ride?
I’ve gone back made sure everything was connected. I did it since it was burning oil and I wanted to see if the rings were bad witch would’ve cause low compression or the valve seals witch would’ve came bad good compression and it was good. I’ve taken it apart 3 or so times to check different thing and I’ve change the plugs and it’s at 84k miles. It started couple hours of driving after the test.
 

·
Registered
Joined
·
1,448 Posts
Sounds like the intake seal rings are not sealing. When installing the intake there is a procedure on what bolts to install in what order. It can be tricky and you probably need to fully remove the intake slowly to see what the seals look like. Any damage and they have to be replaced, they are cheap at the dealer.
 

·
Registered
Joined
·
1,448 Posts
Year is stated as 2012 and with it being misfire 2-4-6 it is obviously a 3.6l Pentastar.
 
1 - 6 of 6 Posts
Top