Dodge Avenger Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi

Had the engine management light on. Fault re EGR valve on a 2.0 CRD.

Changed valve. Reset error code. Light out for 30 miles the¦ back on.

Anyone know where the EGR valve sensor is. Or what it looks like.

Thanks
 

Attachments

·
Premium Member
Joined
·
6,172 Posts
Herein the "Colonies", we're not that familiar with your Diesel engine.. unless some of us also have a Diesel VW. BUT, by the looks of your old valve, I'd be checking the passage that the valve seat allows flow thru...it may be plugged up and causing the code still, that's a LOT of "gunk" accumulated in that EGR valve!
Good luck, and keep us "Colonists" informed on how things go for fixing your rides problem.:)
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Herein the "Colonies", we're not that familiar with your Diesel engine.. unless some of us also have a Diesel VW. BUT, by the looks of your old valve, I'd be checking the passage that the valve seat allows flow thru...it may be plugged up and causing the code still, that's a LOT of "gunk" accumulated in that EGR valve!
Good luck, and keep us "Colonists" informed on how things go for fixing your rides problem.:)
Thanks.

See more gunk. Plus new EGR valve fitted.
 

Attachments

·
Premium Member
Joined
·
6,172 Posts
Follow the vacuum line back from the EGR Valve, I'll bet it goes to a unit with an electrical hook up. And please check that pipe that goes to the bottom of the valve(a thin coat hanger wire will do to see if it's clogged). That pipe should go to the exhaust manifold and needs to be clear for exhaust fume to flow into the valve.
 
1 - 8 of 8 Posts
Top