Dodge Avenger Forum banner

1 - 20 of 235 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
I searched and searched for definitive information for an ETC & ESC dash light (Electronic Throttle Control & Electronic Stability Control). There seems to be some info from 2008, but very little current information. The solutions appeared to be mixed and mysterious. I suspect, a lot of ETC issues were fixed under warranty.

My 2011 2.4L has 30,000 miles. No warranty. The ETC and ESC lights are coming on. (no flashing lights, no engine light, no engine codes)
Sometimes it comes on at slow speed, sometimes at +70mph, sometimes cruising and accelerating. About 10 times in the past few weeks.
When the ETC light comes on, the car won't accelerate and generally starts to slow down to 40-25 mph.
Once you stop and restart the car, it resets and the car runs fine. It may return the same day, or 5 days later.

Based on other threads and searches, I've removed and cleaned the throttle body.
I've taken a bit of a look at the wiring.
Didn't help.
Other threads talked about replacing the throttle sensor or the throttle body.

So, I found a new OEM pedal/throttle sensor for $75 delivered via Ebay.
That went on today. Took one small drive, with no issue.

Please let me know if anyone has any current info on ETC problems, solutions or ssuggestions.

For everyone's information, the throttle/pedal assembly is really easy to replace. Remove the 3 nuts, drop it down. There's about 6 inches of wire. Then unplug it.

The pedal I removed was part number 04891585 AC. The new part was 04891585 AD.

Here's some pictures:






 

·
Registered
Joined
·
870 Posts
Hi
Hope this cures your problem.
Thanks for posting the pics and how to info. I'm sure this will help many people if they ever have the same problem in the future .

:smiley_thumbs_up: :rep:
 

·
Registered
Joined
·
107 Posts
Discussion Starter #7
The problem returned after a couple months.
Took it to the dealer. He cleaned the throttle body and a couple other things I had already done. Charged $300 and didn't replace a thing. God, I love the freaking dealers.

Replaced the battery. The problem disappeared for several months.

It returned last week. Tried disconnecting and reconnecting the battery.
The ESC and ETC lights stay on. Cannot get above 20mph.

Hmmmm. What to try next?
 

·
Registered
Joined
·
107 Posts
Discussion Starter #8
We could not get the ETC/ESC to reset, even with a battery cable remove to reset.
We found a blown fuse. Replaced fuse and had the same intermittent issue as original; ETC/ESC lights on periodically, goes into a limp mode with max speed 20-30mph.

I had to let it set for several days.

Today, I checked and cleaned the battery and ground connections on the driver fender. Drove it. Got the ETC/ESC/limp mode once in 20 minutes of driving. Reset by shutting off for a minute.

The dealer apparently can't do a thing without codes and lights.
Going to try the Throttle Body next.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #9
I just noticed that it's been almost exactly a year since this started.
I can't believe that no one else has had a similar problem.

Don't be afraid to speak up, and let me know what else I can try.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #10
I replaced the Throttle Body today and drove it for about 10 miles in town traffic. No lights, no problems.
The Throttle Body came from Ebay for $200 delivered. p/n 0489 1735 AC
It took about 15 minutes to change. Plug and Play.
Here's some pictures:








 

·
Registered
Joined
·
3,873 Posts
Thanks for all of the information and great pics. Hope this finally solves you problem....frustrating isn't it!
 

·
Registered
Joined
·
107 Posts
Discussion Starter #15
So far so good, but I thought I had it fixed when I changed the battery... that lasted 9 months?!? Anyway, after 11 days, I feeling pretty good.
Before I changed the TB, 20 minutes was lucky.
 

·
Registered
Joined
·
2,959 Posts
sometimes the gears inside the throttle body break and that will throw the ETC light. If you still have the old one, open it up, see if there is anything obvious going on
 

·
Registered
Joined
·
107 Posts
Discussion Starter #18
Throttle Body Autopsy

I finally took apart the old Throttle Body.
As many of you know, it is a sealed unit.
I did see that there is an adjustment screw for the throttle plate. It's a security Torx screw, so adjust at your own risk.

The steel cover is crimped to the aluminum housing, all around. I took a hand grinder to the side of the steel cover, and popped the cover off. I removed the idler reduction gear and then removed the 6? torx screws holding the electronics. I bent half the electronics up, to expose the throttle plate gear.
The motor gear is metal. The other 3 gears are plastic. The small idle gear and the throttle gear were HEAVILY worn at the idle position.

In hind sight.... there was a lot of play in the throttle plate during the first cleaning.
The first time you push on the plate, you may not feel it, because you just pushed/rotated the motor back. The second time you push on the plate, you'll feel the play... and that has to be the worn gear teeth. Note: The throttle plate has its own return spring.

Here are the pictures:


 

·
Registered
Joined
·
4 Posts
hello all

"Hello!
So last winter in New Jersey it was very frigid. When i would try to start my car, the etc light would come on and it would take a few tries but everything would be okay.
its been a year and now the etc light comes on if i dont heat up my car for ten min. it used to come on and go away but the other day it stayed on and didnt go away until i pulled over restarted and the car.
i have a 2011 dodge avenger with 46k miles on it. its dodge express. could it be a sensor? or should i just replace the throttle body completely? I also notice my car engine temperature staying at the half mark now. it used just stay just below the half. but now its steady in the middle. could this be related?
Thank you!"
Also, if anyone can link a how to video on how to fix the throttle that'd be great! Lol
Thanks all!
 
1 - 20 of 235 Posts
Top