Dodge Avenger Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter · #1 ·
So I been having issues with the p0546 code which is small evap leak and loose gas cap off and on worded where mileage is. So I went head and ordered purge, vent and gas cap since is was cheap and started rebuilding a smoke tester I build awhile ago. Before parts came in I smoke test after the purge valve clamped hose after vent valve, it head the 1psi pressure and did not see any smoke( loosen gas cap to see if smoke was there which it was). So I then replaced the parts I ordered and reset ecu with my alfaobd app, didn't see anything for 1 week of 2-3hrs driving daily then it came back so I smoke tested again I put a lil bit more pressure at 1.5 maybe close to 2psi for a short time watching everything but still nothing, my only guess really is maybe electrical or maybe certain vibration causing a leak.
 

·
Registered
Joined
·
4,996 Posts
Are you sure it's not P0456? The 546 code is more to do with exhaust issues.

If it is 456 that's a tough one, since it's a general small evap leak code it could be a tiny leak almost anywhere. Here is a good resource that might help you out:

 

·
Registered
Joined
·
4,996 Posts
I see now that you had the 456 in the title but you transposed it in the body of your text:)
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #4 ·
Yes 456... Yea I even went so far as taking all connects apart that are accessable and cleaned an added some vaseline to the orings
 
1 - 4 of 4 Posts
Top