Dodge Avenger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Hi! I noticed that while the engine is in idle, the front fascia of the bumper and the radiator grile are shacking pretty badly, think which is not normal i thing. Have you noticed that too? What did you do to stop it? Thank you.
 

·
Registered
Joined
·
284 Posts
Check to see if you can shake the rad with the engine off. Sounds like there is a broken weld, missing bolts or both. Did the car ever have an incident with a parking lot mini-curb. Sometimes they can get under the bumper but still hook the rad and lower facia.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #4
My guess is that the engine is causing this. Why am i saying that? Because the structure of the car and all its components that are not part of engine and transaxle were originally designed for an Otto engine and not Diesel. It is well known that diesel engines vibrates more than the others.
The front bumper was removed and reinstalled again twice due to two very small incidents and all the bolts, nuts and clippers are in place for sure, so i was wondering if there is a sollution to this tremble.
Otherwise, no problem. I love the car especially for its diesel engine and this problem is not a problem after all. But i was only wondering if you guys have this issue. It looks like obscure82 has it allready. Ciao!
 

·
Registered
Joined
·
1,341 Posts
Check to see if you can shake the rad with the engine off. Sounds like there is a broken weld, missing bolts or both. Did the car ever have an incident with a parking lot mini-curb. Sometimes they can get under the bumper but still hook the rad and lower facia.
What Marty said... Something sounds adrift! Mine is totally stable, even when it has just fired up. Hope you can get it sorted without too much grief. :smileup:
 
1 - 6 of 6 Posts
Top