Dodge Avenger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
2013 2.4 136000kms. This loud screeching noise just started happening as soon as I start driving. Sometimes it goes away but after awhile the noise comes back. Any suggestions on what it could be?? I’m thinking maybe the hub bearing? Or the brakes? I thought maybe it was a rock in the brakes but I did that thing when you drive in reverse n step on the brakes but nothing noise still there
 

·
Registered
Joined
·
4,217 Posts
Very difficult to say. Did it start suddenly? Any servicing or collision happen recently? Does the sound happen more under certain conditions like turning or braking? Can you record the sound and post it?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
2013 2.4 136000kms. This loud screeching noise just started happening as soon as I start driving. Sometimes it goes away but after awhile the noise comes back. Any suggestions on what it could be?? I’m thinking maybe the hub bearing? Thanks
Very difficult to say. Did it start suddenly? Any servicing or collision happen recently? Does the sound happen more under certain conditions like turning or braking? Can you record the sound and post it?
sorry I should add that it’s coming only from the front left tire only
 

·
Registered
Joined
·
4,217 Posts
I would set the parking brake, lift the front left corner and put the transmission in neutral and rotate the tire manually to listen where the noise is coming from. Then you'll have to pull the tire off for further inspection.
 

·
Registered
Joined
·
1,397 Posts
When were the brake pads last checked? If replaced recently it could be the dust shield bent towards the rotor and rubbing. Next could be the hub, but I would do the other checks first.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I would set the parking brake, lift the front left corner and put the transmission in neutral and rotate the tire manually to listen where the noise is coming from. Then you'll have to pull the tire off for further inspection.
Thanks man I did just that and sure enough it was the brakes! Appreciate the advice big time!
 

·
Registered
Joined
·
4,217 Posts
No problem, great to hear you found the cause:cool:
 
1 - 7 of 7 Posts
Top