Dodge Avenger Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently installed LED Bulbs in my Avenger. I put high beans and low beans. Both are having issues. These are the LED's I bought. 9005+9006 Combo 160W 16000LM CREE LED Headlight Kit High & Low Beam Light Bulbs | eBay

They say they are CANBUS error free but they are having a flashing issue. Its dangerous and weird. Heres a video I found on YouTube of it happening to another car. It's the same exact issue happening to me.
Please tell me how to fix this.
I really appericate it.


Thanks!!
 

·
Registered
Joined
·
4,749 Posts
You'll have to order these to prevent the flickering:
 

·
Registered
Joined
·
25 Posts
You'll have to order these to prevent the flickering:
So the new avengers need a Canbus? I was looking last night about upgrading my headlights to LEDs and searched for that specific topic.
 

·
Registered
Joined
·
4,749 Posts
Yes they do need the anti-flicker to function properly.
 

·
Registered
Joined
·
4,749 Posts
No problem, glad to help:cool:
 

·
Registered
Joined
·
1 Posts
I recently installed LED Bulbs in my Avenger. I put high beans and low beans. Both are having issues. These are the LED's I bought. 9005+9006 Combo 160W 16000LM CREE LED Headlight Kit High & Low Beam Light Bulbs | eBay

They say they are CANBUS error free but they are having a flashing issue. Its dangerous and weird. Heres a video I found on YouTube of it happening to another car. It's the same exact issue happening to me.
Please tell me how to fix this.
I really appericate it.


Thanks!!
Yes they do need the anti-flicker to function properly.
I installed the anti flicker but still have the same issue
 
1 - 8 of 8 Posts
Top