Dodge Avenger Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2012 Dodge Avenger I replaced the oil pan and oil pan gasket on 10/31/20 on 3/28/21 I noticed some dots of oil under my car is it just normal for oil to leak with a car so close to 200k miles? I have no indicator lights on and car drives good
 

·
Registered
Joined
·
4,908 Posts
Doesn't sound bad but at some point you should get underneath there to have a closer look before it gets worse.
 

·
Registered
Joined
·
7 Posts
Make sure its oil as well sometimes the power steering hoses ,o rings can leak a bit and come down the motor mixing with grimes and oils along the way to make it look like oil,can also check around the transmission side of the pan to make sure its not trany fluid . Not sure but sometimes I find things that have happened like this and it tries to make you think its something else when its not. Example....that Rattle noise ...pulley nope...tensensor....nope......compressor nope....power steering nope..... oh its the alternator going bad found it.....how many parts did you replace after that 🤔
 

·
Registered
Joined
·
3 Posts
Make sure its oil as well sometimes the power steering hoses ,o rings can leak a bit and come down the motor mixing with grimes and oils along the way to make it look like oil,can also check around the transmission side of the pan to make sure its not trany fluid . Not sure but sometimes I find things that have happened like this and it tries to make you think its something else when its not. Example....that Rattle noise ...pulley nope...tensensor....nope......compressor nope....power steering nope..... oh its the alternator going bad found it.....how many parts did you replace after that 🤔
Was it the whole alternator or just the stupid decoupler pulley? Seriously why is there a clutch pulley on an alternator. And why is it a $50 part? Ugh. I had a decoupler pulley go bad and it socks to change. I just replaced the whole alt. So much easier.
 
1 - 4 of 4 Posts
Top