Dodge Avenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hey y'all,
I noticed when I stopped at red-lights when coming home from work that my temp. gauge starts to climb, but when I start to move, it goes down. I replaced the thermostat in my car maybe 6 months ago. I checked the fluids and I am all topped off, no leaks under the car that I am aware of (Checked today 2/3/2020). So, I am wondering if it would be the water pump since I didn't have to fill the coolant in my Avenger.
Any opinions welcomed, thanks.

Vehicle Info:
2013 Dodge Avenger 2.4L
124,946 miles
tuned up two months ago
thermostat replaced 6 months ago
no leaks
fluids topped off.
 

·
Premium Member
Joined
·
6,228 Posts
You replaced BOTH T-Stats?????
Do the radiator fans turn on with the A/C or when HOT?
What exactly do you mean by starts to climb? does it actually more the gage needle to top while sitting in traffic and bubbles over? ...You say you have not lost coolant, so I'm trying to understand just what is going on.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
4rebel9,
I have replace one of them forgot about the other, yes the fans come on when hot. When I say the temp starts to climb, I mean when I stop at a redlight or a long light, the temperature will be resting slightly under the middle line for the temperature gauge. After about 20-30 seconds, it starts to climb over the mid point of the gauge. I usually turn the heat on or start to move before it gets to high.
Before the issue started, I know that the temp gauge will hit the middle line and go back down because of the fans, I checked the fans when I got home today and seen that they were running.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
Update:
I have found that it was the 207 thermostat and replaced it. I was more nervous on purging the coolant lines of air since I have never done that before, previous vehicles didn't have them since the gauges didn't work. All is good and now it doesn't over heat, the whole process took an hour. Thanks to all that responded.
 
1 - 5 of 5 Posts
Top