Dodge Avenger Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
2008 Avenger

So my power door locks, interior light, trunk button, and turn signal chime all have completely stopped working out of the blue. I figured that it must be a fuse but I pulled all of the 10-25amp fuses and they're all fine except one for the cigar lighter that has been broken for months but I never really use it so it doesn't bother me too much. Manual says 14 is for interior lights but I pulled it and it looks completely fine. Just to be clear the buttons for the door locks don't work (in the car or on the key), same with the trunk, The interior light won't turn on when I turn the dial, and when I go to put on my turn signal there is no clicking sound like there usually is but the tun signal does come on. All of these things happened at the same time and as far as I can tell not caused by anything that happened while driving, at least not something I noticed, and even though its still fine to drive, it's still pretty annoying, and i'm going crazy not knowing what is is.

Any direction you guys could point me in would be greatly appreciated. thank you so much!
 

·
Registered
Joined
·
3,807 Posts
Hopefully your battery is good. Check and clean all ground connections under the hood. Also remove your TIPM(disconnect battery first) and check all connections coming in at the bottom for corrosion. With so many different problems it could be TIPM related especially with the age of your car.
 
1 - 2 of 2 Posts
Top