Dodge Avenger Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
ok guys ive got a real brain teaser here (or maybe its just me :4-dontknow:). Front passenger power window..rolls down not up. Replaced motor thinking it was bad. Same issue..Ive hooked up a voltmeter to it and its switching between +12 to -12 when you toggle the switch. So i know the switch is good. Is it possible i got a bad motor from the dealership? or am i missing something? Pls help..thanks.
 

·
Registered
Joined
·
69 Posts
I am not sure about the newer models, but you know that the switch is reversing polarity to the motor. Are you measuring this voltage at the switch or where is plugs up to the motor? Just to rule out the motor and mechanical operation of the window try this: Unplug the wiring harness from the motor and try running two jumper wires, one ground and one from the battery (+) side (be sure to fuse the wire). Being careful attach the ground wire to one terminal of the motor connection and touch the other terminal with the (+) wire. If the window goes down then reverse the wires to the terminals, make sure the window moves freely up to make sure there is no mechanical binding or dragging. If you are able to do this and you see no problems then there is either a problem in the switch,wiring harness or connector, and if you have one the relay control board. Each of these can be troubleshooted with a meter. Hope this helps, keep us posted.
 

·
Registered
Joined
·
2 Posts
ok guys ive got a real brain teaser here (or maybe its just me :4-dontknow:). Front passenger power window..rolls down not up. Replaced motor thinking it was bad. Same issue..Ive hooked up a voltmeter to it and its switching between +12 to -12 when you toggle the switch. So i know the switch is good. Is it possible i got a bad motor from the dealership? or am i missing something? Pls help..thanks.
I had the same exact problem, it turned out to be the driver side switch!
 
1 - 6 of 6 Posts
Top