Dodge Avenger Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all, I'm new to this forum, but I'm very familiar. I know there is a vast amount of knowledge in here. I've been a gear-head all my life and I'm usually the go to for most of my family. That being said, my aunt just called me and asked about a red light (not a lightning bolt) in the middle of her speedometer that is flashing. It's also flashing while she's driving. This is an 08 2.4 SFI DOHC. Problem is, I'm in IN and she's in WVa so this is really all I know, I'm not real familiar with the Avengers (yet) and a google search didn't give me a whole lot, except lead me here to the knowledgeable Avenger fanatics. Any insight will be greatly appreciated. She just wanted to know if it is a dire emergency or not.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
I just talked w/ her she confirmed it is the 1 in the center right below 60. :smiley_thumbs_up:

So is there a way to reset the security system? The light is flashing while she's driving, I would hate for her to go into a store and come out to a no start. She's getting ready to come this way for the holidays, hopefully trouble free, I can take a closer look at it then.

My past experience w/ factory alarm sys. has been unpleasant to say the least (familiar w/96-98 Buick Skylarks? :3-smash: )

BTW thanks for the quick replies !
 

·
Registered
Joined
·
1,691 Posts
Weird... Is this a new occurrence? If she uses the key fob to unlock the car it should turn off automatically... Maybe have her try the other key fob? Perhaps the key is losing it's programming?? No idea at all... I would think it wouldn't start if it weren't working correctly.
 

·
Registered
Joined
·
246 Posts
The battery on the fob might be dying. That's my two cents. I would take it to a dealership and see if they have any answer for you. Or have her use the other key for the time being if that one works.

Before that if you have a scan tool it will tell you what the problem would be, so I would try that first.

The Sentry Key REmote Entry System (SKREES), sometimes referred to as the Sentry Key Immobilizer System (SKIS), performs a self-test each time the ignition switch is turned to the On position, and will store key-related fault information in the form of a Diagnostic Trouble Code (DTC) in SKREEM/WCM memory if a Sentry Key transponder problem is detected. The Sentry Key transponder chip can be diagnosed, and any stored DTC can be retrieved using a diagnostic scan tool.


Hope this helps keep us updated...
 

·
Registered
Joined
·
5 Posts
I just talked to the dealership, they want $125 to tell me what is wrong (why the light i flashing). The mechanic said it was new to him, but it sounded like there was a loss in communication.
 

·
Registered
Joined
·
25 Posts
I am having the same issue actually. 2008 Avenger. I noticed on my drive in to work today that it was flashing on and off, or it was steadily on. Strangely enough when I turned the heat off it turned the light off...and when I turned the heat back on the light came on. It didn't do it consistently so I'm assuming it was a coincidence. I work at an auto auction and am going to ask one of our mechanics shortly, but we don't usually have Avengers.
 

·
Registered
Joined
·
25 Posts
Only thing I can come up with on my own is maybe the FOB battery is dying, and a coworker mentioned that his old Buick had a semi-similar issue and he had to replace his entire key.
 

·
Registered
Joined
·
5 Posts
Ok, for my 2008 it turned out to be a wrong key fault. My mechanic took the wrong key and tried to start my car. When he reset the fault it cleared it.

I guess it's Dodge's way of getting money from us when someone trys to start our cars with the wrong key.
 

·
Registered
Joined
·
12 Posts
Wrong key fault

So if it is indeed a wrong key fault causing this, is there a DIY way to reset them? I have a great engine/transmission/ABS code reader/diagnostic tool for my iPhone 5 and obviously it doesn't come up for those.
 

·
Registered
Joined
·
1 Posts
I have a 08 Avenger also and I'm also experiencing the same problem. My light started blinking while I was driving about 2 months ago. But when the alarm light was flashing so was the tire pressure light. But sometimes the alarm light would just flash by itself. The light wouldn't start flashing until I was driving the car for about 20 minutes then it would come on and off. The light would blink like it was a short circuit somewheres in the wires because sometimes the lights would blink on and off fast then at other times its would stay on for a while. I don't think that my problem is the wrong key fault because I do most of my work on my own car and in the passed couple of months when I did take my car to the shop the light had already started coming on. I really need to find out what is wrong with the light flashing.
 

·
Registered
Joined
·
22 Posts
Same problem here. It does this
I have a 08 Avenger also and I'm also experiencing the same problem. My light started blinking while I was driving about 2 months ago. But when the alarm light was flashing so was the tire pressure light. But sometimes the alarm light would just flash by itself. The light wouldn't start flashing until I was driving the car for about 20 minutes then it would come on and off. The light would blink like it was a short circuit somewheres in the wires because sometimes the lights would blink on and off fast then at other times its would stay on for a while. I don't think that my problem is the wrong key fault because I do most of my work on my own car and in the passed couple of months when I did take my car to the shop the light had already started coming on. I really need to find out what is wrong with the light flashing.
 

·
Registered
Joined
·
1 Posts
Hello, I'm new to this forum and I have a 09 dodge avenger and I'm having the same issue as mochacholat. My light flashes any time my tire pressure light flashes. I dont have any of the tire sensors on my car (they were removed at least 5 years ago due to damage and high cost to replace them). The sensor light has been on for the 5 years and just yesterday the red light under the 60 on the dash started to flicker on and off. Any solutions or help with finding out if this is something that needs attention would be great.
 
1 - 16 of 16 Posts
Top