Dodge Avenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hey everyone. So on Monday driving back home from dropping off my sister to school and noticed my temperature gauge shot straight up and got the engine over heating light turned on.
Thankfully I got home and checked the hood noticed that one of the upper radiator hoses was cracked and separated from the filler neck.

I replaced the whole upper radiator hose assembly and now I know I should add coolant
But how or what are the actual steps to do that
I drive a 2012 Avenger SXT 2.4L
 

·
Registered
Joined
·
4,623 Posts
When the engine is cool just top up the fluid at the rad cap and then add fluid to your reservoir to the correct level. Use 50/50 mix HOAT coolant. Check levels after you've run the car for a while. If necessary top up level in you reservoir.
 

·
Registered
Joined
·
1,427 Posts
Be smart and use screw clamps and not the factory spring clamps on the rad hoses. My son's GC had one break causing him some overheat issues.
 

·
Premium Member
Joined
·
6,749 Posts
Be smart and use screw clamps and not the factory spring clamps on the rad hoses. My son's GC had one break causing him some overheat issues.
Must be the difference of where and when the clamp was made and what grade metal(made in China). Both our 04 Neon and T&C have their original spring clamps and doing fine. BUT I totally agree about using good quality stainless steel screw clamps..don't be fooled though, there are real cheap ones of those out there too (you get what you pay for)!
 

·
Registered
Joined
·
1,427 Posts
Since the upper went I would advise doing the lower as well as a preventative measure.
 
1 - 5 of 5 Posts
Top