Dodge Avenger Forum banner

1 - 11 of 11 Posts

·
Registered
2009 Avenger SXT
Joined
·
6 Posts
Discussion Starter #1
Hi everyone, new to the forum.

I have a 09 Avenger sxt, lately I have had to push the shifter forward in order for the car to start, but I get power to everything else, I noticed that the reverse lights are on until I push the shifter then everything seems to go back to normal, but the shifter has seems to be stiffer and harder to move from park to any other gear.

Could it be a shifter cable adjustment ?

Thanks in advance.
 

·
Registered
Joined
·
4,625 Posts
Yes sounds like a shifter issue, may even need a new cable.
 

·
Registered
Joined
·
4,625 Posts
  1. Remove the center console.
  2. Move the gear shifter to PARK and the ignition key to the LOCK position.


BTSI Cable at Mechanism

BTSI Cable at Mechanism


1 - CAM
2 - BTSI CABLE

  1. If the interlock cable is being replaced, remove the pin to allow cable to “self adjust.” Press locking clip by hand to secure adjustment.
  2. If the interlock cable is not being replaced, the pin will not exist. Loosen the locking clip on the interlock cable to allow cable to “self adjust.” Press locking clip by hand to secure adjustment.
  3. Install the center console.


ACTIONEXPECTED RESPONSE
1. Turn key to the "ACC" position and depress brake pedal.1. Shifter CAN be shifted out of park.
2. Turn key to the "ON" position, with foot off of brake pedal.2. Shifter CANNOT be shifted out of park.
3. Turn key to the "ON" position and depress the brake pedal. 3. Shifter CAN be shifted out of park.
4. Leave shifter in any gear and try to return key to the "LOCK" position.4. Key cannot be returned to the "LOCK" position.
5. Return shifter to "PARK" and try to remove the key.5. Key can be removed (after returning to "LOCK" position).
6. With the key removed, try to shift out of "PARK".6. Shifter cannot be shifted out of "PARK".
NOTE: Any failure to meet these expected responses requires system adjustment or repair.

  1. Install the bezel on the shifter console.
  2. Install shifter handle.
 

·
Registered
Joined
·
1,427 Posts
I would also lube the shift actuator on the trans.
 

·
Registered
2009 Avenger SXT
Joined
·
6 Posts
Discussion Starter #7
Update:

I'm starting to think it a transmission issue. I disconnected the shift cable from the trans and the cable moves fine not stiff or binding, tried to move the lever on the transmission by hand with the cable off, it will not move. Shouldn't I be able to move the lever by hand ?

Thanks in advance.
 

·
Registered
Joined
·
4,625 Posts
If the car is parked on a slight grade there will be pressure on the parking brake lock that may not allow you to easily move the lever at the transmission.
 

·
Registered
2009 Avenger SXT
Joined
·
6 Posts
Discussion Starter #9
Dash showed car in Reverse, removed shifter assembly completely from the center console, nothing there now but the shift cable, disconnected cable from trany and cable moves fine not stiff at all.
re-connected cable, and tried to move cable, had to put a screwdriver through the cable end for better grip, had to use all my weight to move it in to Neutral, issue is in the trany.
Your thoughts ?
 

·
Premium Member
Joined
·
6,749 Posts
YES, some thoughts. There have been MANY posts of this SAME problem...with answers. The cable end to the trans selector rod is probably badly worn AND the rod that goes into the trans case is corroded and needs to be sprayed at that spot with a good penetrating oil like PB BLASTER. Let it soak for a few hours, and with the vehicle on a FLAT surface, then start working the selector rod(slowly) to free things up. This is a very common problem with most all FWD transverse engine mount vehicles.
GOOD LUCK!
 
1 - 11 of 11 Posts
Top