Dodge Avenger Forum banner

21 - 40 of 57 Posts

·
Registered
Joined
·
1 Posts
Wow.. sad to see I'm not the only one in this boat..

Thank you SOOOOO much for this post. I successfully fixed my car myself! I was able to find my spring when I took off the console so it only cost me $1 for a packet of "s" hooks. I really could NOT afford a trip to the dealer especially since they would only put the same cheap part back on. It really was not all that hard to fix. Was really glad I only had to take off the plastic console and not touch the shifter or anything. Thanks again!! :smiley_thumbs_up: Oh and since I took the whole thing apart I am going to spray paint the chrome trim that goes around the shifter so that I do not get BLINDED by the sun. One of my pet peeves of the car. I live in Arizona after all and we have sun 360 days a year...
This happened to me yesterday, 2006 Dodge Charger SXT, at work. Luckily my wife was able to leave work to get kiddos, then get me. I WAS going to have dealership fix it, but the towing alone would have been $85, and who knows how much for them to repair.

The instructions are perfect, and will be tackling this later on today or tomorrow morning. As for the use of plastic, :doh:
 

·
Registered
Joined
·
5,222 Posts
This happened to me yesterday, 2006 Dodge Charger SXT, at work. Luckily my wife was able to leave work to get kiddos, then get me. I WAS going to have dealership fix it, but the towing alone would have been $85, and who knows how much for them to repair.

The instructions are perfect, and will be tackling this later on today or tomorrow morning. As for the use of plastic, :doh:
Quite a money saver, huh.
 

·
Registered
Joined
·
54 Posts
Shifter stuck in Park - trying to fix- HELP!

First- thanks so much for this forum, and the very detailed fix written by hkgmillette! My only real struggle to get it apart was 1. getting the parking brake handle up ungodly high 2. not knowing how to get those electrical plugs apart (all different), and how to remove the black transmission cable. I did take the shifter assembly out, as I am not confident in drilling that hole and getting everything right with it in there, like some toher people did.

I was looking for the spring and pulled away the carpet and foam on the drivers side and heard something fall down between the hump and the carpet. So, another 10 minutes to locate the right socket and pull the 4 bolts, and I tilt the seat back, pull on the carpet, and voila!!! A PENNY!!! Cuss and bolt seat back in. Leave penny for posterity.

So, the spring is completely gone. I have no idea where it went. I see the 3/4" s-hook and 1" spring, but is there any specific spring tension or anything? I know I can get the s-hook at a hardware store, but are they going to have the spring too? Or is that more of an auto part?

I know NOTHING about springs, but for a 35yo mom of 2 girls I think I'm doing pretty damn good :)

Any help appreciated!!

update 7/24/10- it's fixed!!! See my other thread! http://www.avengerforumz.com/showthread.php?t=44800
 

·
Registered
Joined
·
7 Posts
Discussion Starter #25
You should also be able to get the spring at the hardware store. The tension on the spring does not have to be that strong, very low tension. The spring just needs to move the pink piece when you start to move the shifter out of Park. Just watch the length. IF it is to long, it will have the possibility of becoming disconnected when the car is in gear. If this happens, then you are right back to where you started, Shifter stuck in Park.
 

·
Registered
Joined
·
1 Posts
Great solution. I will give it a try. Don't have the money to get it repaired at the dealer. But that S hook looks like a great solution. Where would I be able to purchase the spring? Would that be available at a hardware store too?
 

·
Registered
Joined
·
1 Posts
Lifesaver

AWESOME... This really saved me...AND made me look good to the wife! The avenger is her car...and she took mine to work when this happened. The spring was there on the floor when I took the console off. To have this done in under an hour and have her car fixed, washed, and running made me look like a superhero. You ROCK! :smileup:
 

·
Registered
Joined
·
31 Posts
I'm actually thinking of doing this this weekend as a pre-emptive strike so it doesn't break when my girlfriend is coming home from college at 10:30 at night. Awesome write up and thanks
 

·
Registered
Joined
·
6 Posts
If it does happen, DON'T TEAR INTO THE CONSOLE. You're much better off just to disconnect the linkage from the top of the trans unit and shift it by hand. It takes two people to do safely, one should be on the brake. The lever is visible from the top, right below the TIPM. Don't burn yourself, let the vehicle cool a bit, and the PRNDL will show P the whole time so you'll likely get a MIL. Take it to the dealer and they should be able to take care of it pretty quickly. If you're still in Basic, call Cross-Country for towing, the number is in your owners manual.
hkgmillette has the right idea. I've put a small bolt in them before and it fixes them just as well and all connections are secure. And yes the Autostick shifter does the same thing. Same fix as well. The new design is different, remember Mercedes' pay plans were based on how much you could "NOT SPEND" on a part. I'll agree it's a POS design, but I love my car.
 

·
Registered
Joined
·
1 Posts
This was a lifesaver. I did not want to spend the money to replace that whole unit.

Actual reason for this post was to say that I was able to find the stock spring but it wasn't strong enough to do the job after I installed the S, It moved the mounting location so the two mounting locations were too close to each other. I was able to modify the location to get it to work by closing the bottom part of the S and putting the spring above it. Sorry I didn't think to take a pic and I'm not tearing it apart again. A way to avoid this would probably be to drill the hole further to the front side of the pink thing that you can. Just a heads up.
 

·
Registered
Joined
·
7 Posts
This happened to me after work tonight! Ugh. After working 8 hours dealing with difficult people, I was NOT happy. But I called the Hubby and we looked up AvengerForumz on our cell phone. Voila! We got it out of PARK thanks to this post!! I had no idea this was a common problem. I will be taking it to the dealer and making them fix this since I have some other issues they need to fix as well.

Thanks again!!
 

·
Registered
Joined
·
4,754 Posts
Glad to hear you found this thread and got your Avenger home without having to tow it.

Also, welcome to the forumz! We welcomed your husband already but haven't officially welcomed you yet.
 

·
Registered
Joined
·
7 Posts
Thanks. :) After solving our little problem last night, I figured I should probably join the forumz.
 

·
Registered
Joined
·
1 Posts
I just want to say that I really have no experience with working on cars myself, but thanks to this post I was able to fix this problem in about an hour and with a cost of about $3. Thank you!!!
 

·
Registered
Joined
·
9 Posts
I love this site.

happened to me an hour ago. first thing I thought of was to go to this site. Great post and even better detailed procedure!n rep coming your way! really... plastic?:thk:
 
21 - 40 of 57 Posts
Top