Dodge Avenger Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have this loud squealing noise when I drive and when I turn ac on it gets really bad especially fresh starts but slowly has gotten worse i just replaced my alternator so I replace the pullys to the belt along with a new belt any thoughts im thinking compressor pulley is going bad
 

·
Premium Member
Joined
·
6,528 Posts
Could be possible,BUT did you replace the automatic tensioner and it's pulley first? Have seen a few postings of the tensioner itself going bad and this would cause a belt squeal condition.
 

·
Registered
Joined
·
1,393 Posts
Did you also replace the idler pulley? Is the crank pulley properly lined up. I had mine start to come off and get misaligned and created a load squeal.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Yes I did and im not sure how to adjust it or check the belt was misaligned once but not again
 

·
Premium Member
Joined
·
6,528 Posts
The tensioner itself was replaced? I've seen posted and have experienced(with my T&C's) the spring load of the tensioner go bad, not giving enough tension to the belt.
 

·
Registered
Joined
·
4,138 Posts
Could be one of the other accesories wearing out like your AC compressor or power steering pump.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
So a little more information from driving around messing with it to see when its the worst. When I am in drive not moving i.e. stop light, drive through it gets real bad but in neutral and park just idling it doesn't do it.
 

·
Premium Member
Joined
·
6,528 Posts
So a little more information from driving around messing with it to see when its the worst. When I am in drive not moving i.e. stop light, drive through it gets real bad but in neutral and park just idling it doesn't do it.
So What does it do with the same "parameters" AND the A/C turned OFF? If it does NOT squeal then but with A/C ON, then you probably have an A/C compressor problem.
Did you replace the auto tensioner ARM or just the pulley on it and the separate Idler pulley? A WEAK tensioner arm(spring loaded) can cause belt squeal.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
It stops when the ac is off and yes I did i replaced the whole tensioner unit pulley and all along with the idler pulley
 

·
Premium Member
Joined
·
6,528 Posts
I would then suggest you get to a shop that can diagnose and repair the A/C system. I have not heard of widespread compressor problems on the "facelift" later model years but the 08 and 09's were a big trouble spot.
Had you "topped up" the R-134a recently? an overcharges of refrigerant can cause problems in the compressor, making it turn harder which would lead to belt squeal.
 
1 - 13 of 13 Posts
Top