Dodge Avenger Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
My dodge avenger sxt 13 2.4l started leaking from the bottom of the thermostat housing. I guess the return? Idk but I took off the housing and looked at it for cracks and what not. The o ring was old so I changed it, changed the thermostat 170 and put it back on, the 230 was still good. Refilled the radiator and started it. I let it run and run. I said okay its fixed. So I did a test drive.... nope the temp kept jump from running temp and over and then back. So I opened it. Did a little squeeze and it started coming out from the bottom. I don't know what I did wrong... I made sure I didn't over tighten since I didn't have a torque wrench. I tightened until it didn't go freely then did one little tiny make sure its tight. What should I do?
 

·
Registered
Joined
·
4,625 Posts
You will probably have to change the whole thermostat housing.
 
  • Like
Reactions: EvilRedLion

·
Premium Member
Joined
·
6,749 Posts
Member Intrepid is correct in his reply to you. The housing assy. is a known issue with the 2.4 motor. The wide heat range of temps the plastic is subjected to is the long term culprit to them cracking. The early models were even more notorious and had a redesigned unit to replace them. Unfortunately it's the same design used in your year and they still can leak.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Member Intrepid is correct in his reply to you. The housing assy. is a known issue with the 2.4 motor. The wide heat range of temps the plastic is subjected to is the long term culprit to them cracking. The early models were even more notorious and had a redesigned unit to replace them. Unfortunately it's the same design used in your year and they still can leak.
Does the water pump inlet tub have a plastic ring and then a oring around it?
 
1 - 4 of 4 Posts
Top