Dodge Avenger Forum banner
1 - 20 of 23 Posts

·
Banned
Joined
·
807 Posts
Discussion Starter · #1 ·
took it in to the shop today for the tranny, dift dealer. they ran the code box and there was a error (to lazy to go down and get the slip) and they said it was down 3/4 of a quart. no leaks seen though
 

·
Registered
Joined
·
68 Posts
How new is the car, Mine was low from the factory and that is a common code for a low fluid condition. Trans can't "burn" oil so if no leaks are seen, keep an eye on it and you should be ok if they topped the fluid off. The Chrysler scan tools dont give a normal print out, must down load a file to a normal computer to actually print the codes and that is a real pain in the butt to do so don't expect it.
 

·
Registered
Joined
·
1,529 Posts
Well its a good thing they caught it. I miss be able to check your own levels though. IIRC, you need something special or theres a special way to do it on this car? My old contour just had a handy little dipstick. I think I went 140k in that car with no trans fluid change or loss of fluid lol. It took a beating. :p
 

·
Registered
Joined
·
1,529 Posts
check some models have a dipstick and some don't...Mine has one 2.7V6 w 4speed automatic. same trans in all 2.7 and most 2.4 auto's

Thanks for the infos! I will have to take a look when the weather gets a little better around here!
 

·
Banned
Joined
·
807 Posts
Discussion Starter · #10 ·
looks like they finally replicated it or at least just said they did, there was another error loss of prime so they had to order a part
 

·
Registered
Joined
·
1,529 Posts
looks like they finally replicated it or at least just said they did, there was another error loss of prime so they had to order a part
Good that they could replicate it so you can get it fixed up!
 

·
Banned
Joined
·
807 Posts
Discussion Starter · #13 ·
going back, same issue and now theres no power. i can have my foot to the floor and it just puts up the hill. like driving through cement
 

·
Registered
Joined
·
11,015 Posts
So are you almost ready for Lemon Law rules to apply? I would see what they can do, but if they can't fix it, then I would see what other options you have.
 

·
Banned
Joined
·
807 Posts
Discussion Starter · #16 ·
they've been ready, this is my complaint i had the other day

"customer states car will not accelerate after pump put in still seems to be putting up hill even with pedal to the floor."

the response i got was car working as it should be no codes found

road tested to confirm complaint, there is nothing wrong with this vehicle, this car does not have alot of horsepower.

well first off i have had a 175hp 2.4 saturn ion and I know what acceleration is.

my current avenger has the 2.4 173hp and before they took the tranny apart i actually had power. really starting to piss me off
 

·
Dodge Avenger Forum
Joined
·
1,340 Posts
they've been ready, this is my complaint i had the other day

"customer states car will not accelerate after pump put in still seems to be putting up hill even with pedal to the floor."

the response i got was car working as it should be no codes found

road tested to confirm complaint, there is nothing wrong with this vehicle, this car does not have alot of horsepower.

well first off i have had a 175hp 2.4 saturn ion and I know what acceleration is.

my current avenger has the 2.4 173hp and before they took the tranny apart i actually had power. really starting to piss me off
Can you go to a different dealer?
 

·
Registered
Joined
·
11,015 Posts
I would take it elsewhere... The last time I went to my local dealer, I told them they were not looking hard enough for a noise in the right front shock... they told me to go get a second opinion... lol. I would tell them to drive a new SE, and then drive yours and see if they can tell a difference... or just ask them if you can drive a new one to check it out. Just my two cents...
 

·
Banned
Joined
·
807 Posts
Discussion Starter · #19 ·
ive been to 2 dealers so far. first one couldnt do it, second one at least verified my issues and replaced the pump.

i guess i need a third one now
 

·
Dodge Avenger Forum
Joined
·
1,340 Posts
You won't find anything I'm afraid. :(

The transmission in the R/T is a sealed unit. You have to take it in for service to have the level checked.
I had just read in the owners manual about having a professional check the fluid. What next? I don't have the R/T anyway,But still what the heck!
 
1 - 20 of 23 Posts
Top