Dodge Avenger Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Okay guys...I have researched this for days now and I am amazed how hard this is. I have an 08 avenger R/T that has factory Uconnect built in. I originally had a 6 disk changer installed but got a RER mygig with nav for free so I hooked it up. Great. Now my uconnect doesn't work. I have found that this is because the factory Uconnect is conflicting with the Uconnect module that is built in to the Mygig with nav.

Okay.....I have found aftermarket microphone kits for the mygig but I really want to use the factory rear view mirror mic. what wires would I need to splice, cut or rip out of this damn thing in order to hook up the factory rear view mic to the new mygig? I know Dodge is comming up with a jumper harness but this is just to far out. There has got to be a way to just bypass the factory unit and splice in to the wiring that goes from the mirror to the factory uconnect module, and route that to the back of the radio. Right?

It is my understanding that the avenger had the option for Mygig with uconnect. If that is true then there must be a factory harness that goes from the dash, straight to the mygig unit.


HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 

·
Dodge Avenger Forum
Joined
·
1,340 Posts
What doesn't work? The mic and audio through the speakers? Or just the mic?

Since the Avenger does have MyGig option, I can't imagine there is much of a difference in the wiring harness. Were all the connectors the same?

I don't understand how it could 'conflict' with the u-connect built into the mygig, since the factory u-connect was also built into the radio you removed - so it is also removed.

From a production stand point, it would seem that any car getting any of the u-connect radios would have the same wiring harness - the only difference being the radio installed. This is just thinking outloud, I haven't spent days researching this as you have. Then again, if the connectors were not the same, they obviously don't have the same wiring harness.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #3 ·
The mic does not work. Basically, the mygig will pair with my phone but will not pick up any voice prompts. All the connections were the same. From what I have found out, the Mygig unit is the only unit that has the Uconnect module built in to the radio itself. All the other radios use an external Uconnect module
 

·
Dodge Avenger Forum
Joined
·
1,340 Posts
I just did some quick research and it looks like the jumper harness (coming sometime in the first quarter of 08) would be the easy way.
I agree with you about snipping and splicing a few wires though. The only way I can think of finding which ones, would be to physically trace the wires from the mirror on both your car and the one that the MyGig came from.

I just noticed your stats. :wow: It shows
Vehicle: Avenger R/T
Trim Level: SE

Must be a one of a kind :D
 
G

·
The mic does not work. Basically, the mygig will pair with my phone but will not pick up any voice prompts. All the connections were the same. From what I have found out, the Mygig unit is the only unit that has the Uconnect module built in to the radio itself. All the other radios use an external Uconnect module
I've got the same problem.
Maybe a stupid thing, but check if you even got the mic. If you've taken the 'Navigation pack', it should be an automatic day/night mirror with build-in mic.

I don't have it... :gy:
Apperantly there are some factory delivering problems with the mirror/mic (so told my car seller). So i've got to wait, and wait, and...
 

·
Registered
Joined
·
1,529 Posts
I've got the same problem.
Maybe a stupid thing, but check if you even got the mic. If you've taken the 'Navigation pack', it should be an automatic day/night mirror with build-in mic.

I don't have it... :gy:
Apperantly there are some factory delivering problems with the mirror/mic (so told my car seller). So i've got to wait, and wait, and...

Jeez...I can't believe they would ship the vehicle in that state. :/
 
G

·
Maybe i've pushed them a little bit to deliver it in a hurry. I knew that the 'Navigation pack' will be in backorder.
But the didn't talk about the mirror ...
At least i've got a working stereo and gps. Now a little patience for the mic...
 

·
Registered
Joined
·
11,015 Posts
Yeah... I wish you the best of luck. You may even find a stock mirror on eBay that has the mic in it. I just saw one on there a couple days ago.
 

·
Registered
Joined
·
1,529 Posts
Maybe i've pushed them a little bit to deliver it in a hurry. I knew that the 'Navigation pack' will be in backorder.
But the didn't talk about the mirror ...
At least i've got a working stereo and gps. Now a little patience for the mic...
Well depending on how well your phone works with uconnect it may not matter. That said, mine works poorly, so I have ceased using the unconnect. Not to mention the BT eats my batterys.
 

·
Registered
Joined
·
610 Posts
I am not sure but I do beleave there is an update for this problum...I have read somewere...but I may be wrong...That there is a software up date for the my gig and uconnect sys. I would check with the dealer.
 

·
Registered
Joined
·
1,529 Posts
Its just my bad luck for having a crappy pda phone lol. I'm waiting for my contact at harmon becker to get back to me with an update. Was supposed to be a month ago, but got delayed.

By the time the update is out though, I will probably have a different phone lol.
 

·
Registered
Joined
·
112 Posts
Its just my bad luck for having a crappy pda phone lol. I'm waiting for my contact at harmon becker to get back to me with an update. Was supposed to be a month ago, but got delayed.

By the time the update is out though, I will probably have a different phone lol.
Are you sure it's your phone? Not a Verizon customer by chance are you? I've got a PDA phone (Sprint 6800) and UConnect works perfectly. My only issue is the person that decided our cars shouldn't have steering wheel controls for it should be fired heh.
 

·
Registered
Joined
·
1,529 Posts
Are you sure it's your phone? Not a Verizon customer by chance are you? I've got a PDA phone (Sprint 6800) and UConnect works perfectly. My only issue is the person that decided our cars shouldn't have steering wheel controls for it should be fired heh.

My car has steering wheel controls...but yes I am a verizon customer.

I spoke with the guys at Harmon Becker and they said it was a bluetooth problem with some phones, so they have a engineer working on it that contacts me every once in awhile and was supposed to have an update. At any rate, I have a Motorola Q, and its a pos in my opinion. I bet if I had a 6800 I would have less issues.

Basically, in my mind, moto q's are crappy pda phones. My ne2 comes up in 2 months though..so I will probably go back to a regular phone. My step daughter just got a voyager, waste of money imo, because she can't afford a plan to be able to use all the features, so she has basically a $300 enV, but ok enough ranting lol.
 

·
Registered
Joined
·
112 Posts
My car has steering wheel controls...but yes I am a verizon customer.
We unfortunately do not have steering wheel control of Uconnect. A major oops! In my opinion.

You should check and see if people with another provider that offers the Q are having problems as well. Verizon has a habit of crippling Bluetooth in their offerings so that may be the case here as well. I know that I have read issues of Verizons XV6800 having problems with the Sync system but. When I was testing cars the Sync equipped ones worked perfectly with my phone.
 

·
Registered
Joined
·
47 Posts
I have an Apple iPhone and it works fine. If I remember correctly, people on tomtomfourms.com have reported issues connecting the Moto Q with a TomTom GPS.
 

·
Registered
Joined
·
70 Posts
Verizon phones have issues. I have a LG VX8350 and it doesn't work at all. I've been very disappointed with the MYGIG system. Its behind in almost everyway.
 
1 - 17 of 17 Posts
Top