Dodge Avenger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey new here im Dee. I have a 2014 dodge avenger sxt. Here's the problem I'm throwing a code P0869. I looked it up -LINE PRESSURE HIGH. Ok so how do i fix it? I've taken it to a transmission shop 2 months ago he drove it around said there was nothing wrong with he trans and cleared the code. The code came back. Been driving it for the past month and half. A week ago it double shift when I was passing someone. I went to slow down to maintain my speed and it would allow to go more than 20mph. Would not shift. So today I took it back to the same tranmission shop told them what happened he drove it again and said i needed a new transmission and they gave me 2 printouts of cost. Before I left he went out and cleared the codes. I got into drive it and the check engine light didn't come on and it started shifting just fine. Talked to my aunts mechanic husband and he said its the tcm. So I guess my question is do I need a new transmission or do I replace the tcm. And if I replace the tcm where is it located and whats the price and do I have to get it at a dealership? Please help. Thank you.
 

·
Registered
Joined
·
40 Posts
Do you have the 4 speed trans or the 6 speed? The first thing I would replace is the trans fluid pressure solenoid as it's only like $30 from rock auto. The double shift could be caused by bad line pressures and so can the limp mode. They can also be caused by bad line pressure readings throwing off the shift timing.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I have a 6 speed. Everyone wants me to sell it. But this car is my baby. And my dream car. But I don't want to be constantly throwing money into it. I feel like I got taken a little from the guy I bought it from. Alot of the parts you can tell have been replaced. I've looked up the car fax and it didn't say it was in a wreck. But might not of been reported too.
 

·
Premium Member
Joined
·
6,635 Posts
Posting the actual code(s) by number would go a long way in others trying to assist you. SYMPTOM descriptions can mean many different things. Solenoid pack of the trans are pretty common to go bad on the 6sp. That's how I got our 2011 Journey 3.6 AWD so cheap. The solenoid pack is a LOT cheaper than other stuff involved and did the trick for our Journey(same trans, only AWD takeoff added on)
Also, I hope you had NOT recently had a trans FLUSH service done...a big problem point on these trannies., drop the pan and change the filter and add back the approx 4 quarts of ATF+4
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I did post the code in original post. And no haven't done a trans flush. And I won't have it done either. Just seeing what other might suggest or say. Im on disability so don't have alot of extra money to work with.
 

·
Premium Member
Joined
·
6,635 Posts
The P0869 is the only code or were there others?
Causes of this code are easily found with a google search of the code number, but I'll list them here for you anyway for all to know what has to be checked to pinpoint the cause for a fix..
1 low or dirty trans fluid
2 faulty trans fluid pressure sensor
3 sensor harness is shorted or open (breaking or rubbed wired)
4 poor electrical connection in pressure sensor circuit.
Personally not knowing what maint has been done and if over 60k miles, I'd change the trans oil and filter first as suggested prior.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I've done research on them. The other codes it threw were
P0572
P0933
P1745
I've fixed everything else.
 
1 - 7 of 7 Posts
Top