Dodge Avenger Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi I have a 98 Dodge avenger 2.5l and I Kno I have a bad injector that needs replaced. Going to do. That as soon as it gets here but I was wondering would that make a car stall at slow speeds?
 

·
Premium Member
Joined
·
6,466 Posts
Flooding out a cyl. and such as that does, it can. but need to do deeper checking of spark plugs/wires/cap and rotor condition while you have it apart for that injector. Also check the vacuum lines and EGR valve. These old motors are pretty sensitive to such things.
Good luck and hope to hear more from you! :)
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thanks for the advice. I am planning on doing spark plugs wires cap an rotor all at the same time as the injector. And a new fuel filter. I just got this car an I don't think it's had a tune up in a while. I will also try to figure out checking the EGR like u mentioned
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
I am also wondering what a bad injector does to fuel trim on a scan tool. I got a p0206 code and my stftb2 is super high and doesn't move at all when revving the engine. Does anyone think that is from my injector not working? Or could it be a o2 problem or something else.
 

·
Registered
Joined
·
4,044 Posts
That code is pointing to injector #6. Try to swap out another injector from one of the other cylinders and see what code you get.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
Well I replaced the injector and the code didn't come back. The fuel trim is better but I did unhook the battery. Replaced plugs and wires and fuel filter. Hoping it fixes my stalling issues. I still planning to replace cap and rotor and idle air control valve waiting for them in the mail. If that don't fix my stalling issue when stopping planning on plugging off EGR.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
So whatever was wrong got fixed. No more stalling no more codes. But I'm still install IAC and cap n rotor sense I already ordered it. Does anyone know if a base model 98 Avenger has Abs breaks. Or how I would tell if it did.
 

·
Premium Member
Joined
·
6,466 Posts
glad to hear that the motor is responding well now, consider the rest of the work as PREVENTIVE MAINT.
Easy way to tell is to turn the ig. key to the run position(also will show all dash warning bulbs) and see if a YELLOW warning bulb with ABS is illuminated. My 98 ES has a lot of the options, minus sunroof AND NO ABS Pretty sure it was an OPTION for all but NOT standard equipment till the last 2000 model.
 
1 - 11 of 11 Posts
Top